Drupal developers released security updates for versions 8.8.x and 8.7.x that fix two XSS vulnerabilities affecting the CKEditor library.
The Drupal development team has released security updates for versions 8.8.x and 8.7.x that address two XSS vulnerabilities that affect the CKEditor library.
Drupal uses CKEditor, it has updated to version 4.14, which addressed two cross-site scripting (XSS) vulnerabilities.
“Vulnerabilities are possible if Drupal is configured to use the WYSIWYG CKEditor for your site’s users. An attacker that can create or edit content may be able to exploit this Cross Site Scripting (XSS) vulnerability to target users with access to the WYSIWYG CKEditor, and this may include site admins with privileged access.”
Both issues have been rated as a
Drupal 8 versions prior to 8.7.x have reached end-of-life and will not receive security updates, Drupal 7 is not affected by the issue, but it is recommended the use of CKEditor version 4.14 or higher.
The risk of exploitation of the flaws could be mitigated by disabling the
According to the release note published by CKEditor 4.14 the flaws are not easy to exploit.
For example, one of the XSS flaws affects the HTML data processor, it could be exploited by tricking the victims into pasting malicious HTML code into the editor, either in WYSIWYG mode or source mode.
The other issue impacts a third-party plugin named WebSpellChecker Dialog plugin that is included in the Standard and Full presets of CKEditor 4. This issue could be exploited by an attacker that tricks the victim into switching CKEditor to source mode, pasting malicious code, switching back to WYSIWYG mode, and previewing the content on a page where the WebSpellChecker Dialog plugin files are available.